Wave Automotive Bundle for Higher Gear (includes Higher Gear Adapter and Campaign Tracker)

Important!   The Wave Automotive Bundle requires Wave versions 4.0, 4.5, 5,0, 6.0, or 7.0.

Licenses are delivered via e-mail, typically within 24 hours.